[0.12.6 - 0.12.10] Windows - Slayer of T'mere M'rgo achievements granted shortly after loading game, without having defeated god

Included below is a zip file with two save files. The first one is “save fresh”, which is from 0.11.5, and in my case, results in me earning Slayer of T’mere M’rgo I-X after about 20-30 seconds. The second one is “save AG unlocked”, which is after unlocking Amalgam Gardens, and shows that I inexplicably have 123 kills on T’mere M’rgo.

saves.zip (228.6 KB)

Edit: Changed the title and category. Glitch may have been present before 0.12.6, that’s just when I began using the 0.12.X update.

Edit 2:
To give an update, it’s still happening as of 0.12.10. It appears as though the cause has something to do with the Cleric and Inquisitor classes, as they both trigger the same glitch, though I have not yet had the chance to investigate the specifics of either just yet, or if any specialisations unlockable later on also trigger it.

To reproduce, do as follows:

  1. Take a save from 0.11.5 with the Inquisitor or Cleric specialisations unlocked. It does not appear as though you have to have these equipped, simply unlocked.
  2. Update to 0.12.X.
  3. Wait about 15-20 seconds.
  4. Enjoy all of the Slayer of T’mere M’rgo achievements.
1 Like

Hello, I’m having the same issue and I know only another person (unless it’s you from discord) who has it too so that’s very rare I think. We should try to find out what we got in common to maybe find why it’s happening. I could have just used your save to find out but I don’t want to get steam achievements from doing so. I run on Windows 11. Last realm I went in was the cutthroath jungle using the ascended evoker. My only other ascension is the cleric. I can share more but I don’t know if it got anything to do with it.

Interesting. Good to know I’m not alone. That being said, I did a bit more tinkering just now. First, I made a fresh new file in 0.11.5, brought it forward to 0.12.9, to see if it was anything in the save file itself. Then I tried deleting the config.sav file, to see if it might be a result of updating the config. In both cases, the game still gave me the achievements. I have not yet checked to see if the kill count remains the same, though I imagine it does.

I have also tried taking actions before the achievements appear, such as entering a realm, saving and exiting, entering the GotG, and entering the arena. None of these seemed to cause any change.

So far, the only case I find it not occuring in is when I make a new file in 0.12.X, as I have tried doing so in both 0.12.7 and 0.12.9, and had no issues. So, it looks like it’s probably occurring when the game updates a save file from 0.11.5 to 0.12.9, and it doesn’t seem to discriminate between classes, game progress, or save file number.

I’ll play around with this some more when I next get the chance, see if I can find anything that causes it not to occur between updates. For the meantime, provided below are the set of saves from the most recent experimenting. Slot 1, Reade, is my main save, still showing the same glitch. Slot 2, Test1, was the save made in 0.11.5 and carried forward immediately into 0.12.9. And slot 3, Test2, was the save made in 0.12.9.

saves2.zip (170.8 KB)

If there’s anything anyone can thing to try, or anything else I can provide, I’m all ears.

I tryied the same as you and the new save file I created in 0.11.5 to 0.12.9 didn’t get the achievements after the unicorn vivifier fight at the tutorial. I did it a second time and it didn’t give it still. I also kept the same config. New file created in 0.12.9 didn’t have achievements and both were animators.

Slot 2 is 0.12.9 and slot 3 is 0.11.5.

saves Kirussen.zip (29,1 Ko)

Oh! Doing a new save in 0.11.5 with cleric as starter and then going into 0.12.9 gave me the achievements. My main game started as a cleric. Did you too? That would explain why it’s rare if it’s only one of the 15 starting specialization. Note that I only tested 2 out of 15.

Save 0.11.5 cleric.zip (14,5 Ko)

Edit: I tryied the hell knight and it didn’t give the achievement. (3/15). I will try more specializtions tomorrow if it isn’t fixed yet.

Good catch. I’m now going through the specialisations and trying all of them. I’ve done Animator through to Defiler so far, and Cleric is the only one who of those 5 that triggered this glitch. I’ll update this post and the top post after I’ve gone through all of them, but it does look like it’s just having the Cleric specialisation unlocked.

As for my main save, I mostly play Paladin there, but I have Cleric and a handful of other specs unlocked, so that feels consistent.

Edit:
Cleric and Inquisitor both trigger it on my end. There might be more classes that cause this outside of these two, but I’d need to do some serious grinding to figure that out though. Easy enough to re-create and test yourself, and still happens in 0.12.10. Just create a Cleric or Inquisitor in 0.11.5, or potentially have them unlocked, and bring the file forward into 0.12.10.

This bug has already been fixed but old save files will be affected permanently, so some people are going to have some achievements that are unlocked prematurely. Unfortunately, there’s no way for me to fix this.

1 Like

Just wanna make sure there’s no miscommunication here. By “old save files”, do you mean files that were brought into the 0.12 cycle while the glitch was still active, or do you mean all 0.11.5 files that meet the parameters for this to occur?

I ask because this is happening with saves made today in 0.11.5 with the Cleric and Inquisitor specialisations, and then brought into 0.12.10.

Either way, thanks for your work, and hope the rest of the polishing for this patch goes smoothly!

This bug has technically been around since day one but no one ever noticed before this patch brought it to light. So any save file created before it was fixed (including before the test branch) could have been affected, but most people probably won’t run into any issues anyway.

1 Like