0.5.6 Stuck in Decoration Mode

Game version: 0.5.6
OS: Windows 8.1

In Decoration Mode, I tried to place a new player spawn location while one already existed. I received the message about my castle already having too many of that object, and then I was unable to use the Q key to cancel out of the placement mode of the spawn point. I could still use the movement keys to move around and the E key to keep receiving the error message, but the Q key was not responsive in any way so I could not get to any menus. I had to close and reopen the application.

I then learned how to move or remove the existing objects by interacting with them right after entering decoration mode and was able to move the spawn point with no issue.

Steps to reproduce: Aside from above, in case it makes any difference: I had also just turned in 2 new projects (gambling dwarves and refinery) and placed those in my castle. I had also changed the floor style and music, and attempted to move the summoning brazier by placing a new one (again, did not know how to move it yet). I did not have an issue canceling out of the summoning brazier placement.

I did this. I wasn’t thinking and tried to place a new player spawn place instead of moving the existing one. It wouldn’t let me do anything to cancel out and it kept flashing the message about already having one. I had to alt 4 to close out.

Thanks, fixed for the next patch!