1.0.0 - Linux- Game Randomly Registers Inputs

The game seemingly randomly acts as though it is recieving inputs, almost always ‘E’, when in every menu I’ve been in, including the main menu, save slot selection, name input, and class selection, as well as the dialogue in between those menus. This has happened on every one of the 4 or 5 times I’ve booted up the game. The interval between each input isn’t precisely consistent, but it does tend to speed up and slow down. There was one time that the game was also registering ‘S’, but it has only happened once.

Check to make sure you don’t have any gamepads connected via USB or Bluetooth that you aren’t using. There may be a driver issue with your gamepad(s) as well.

I’m using the keyboard, and don’t have any gamepads plugged in, nor are any listed as connected over bluetooth. I turned off bluetooth and tried it again, just to be certain, and it still did it. I tried plugging in the gamepad I use, a Switch Pro Controller, and the random ‘E’/Accept inputs continued, and the game was also constantly recieving a down input. I double-checked the controller with another game, specifically Bug Fables, to make sure the error wasn’t on the controller’s end, and it functioned normally there.
I am using dkms-hid-nintendo instead of the Steam drivers for the Pro Controller, so that I can use it with games not running through Steam.

I restarted the game in between each of these attempts, by the way. I’ve not tried changing the input method while the game is running yet, since that tends to cause problems, rather than fix them, in my experience.

I just tested it, and both the keyboard and the controller work fine when using the Windows version through Proton.

Thanks for the additional info! Did you play the game without issues before 1.0.0, or are you new to the game?

I’m new.

To be honest, I’m not sure what the problem could be if there aren’t even any gamepads attached. The only thing I can think of is to maybe reinstall your keyboard drivers, but I’m doubtful that would work. I haven’t heard of this issue from other Ubuntu users and can’t reproduce it on my end either. I know this isn’t the ideal solution, but if you’d like a refund, you can either get one from Steam if you’ve played for less than 2 hours or otherwise I can issue you one via PayPal. Just let me know!

Oh, that might be it. I’m not on Ubuntu, I’m on Manjaro. Sorry about that.
I’m not planning on refunding it. It seems to run just fine through Proton as far as I can tell, so I’ll just use that.

1 Like

Disabling gamepad support may help. It worked on Windows when someone else had the game falsely detecting a gamepad as present
Options → Controls
image

Okay, I went to test this, and I figured out what the problem is. I’m on a laptop, and since I have a usb mouse I disabled the touchpad basically as soon as I got it. However, for whatever reason, Siralim still registers touches to the touchpad, and so when I rest my hand on it, as I tend to do due to its positioning, Siralim is constantly registering mouse clicks. I’m not sure why it does this, but I tested it, and Siralim also doesn’t respect key binding changes, as I’ve rebound to the caps lock key, and it doesn’t notice that either. I’ve had the escape rebind not get noticed by other games before, notably Warhammer Total War, and I’d guess that the touchpad still works there too, and I just never noticed it.