1.1.1 - Yseros exhalted quest triggered early, now incompletable

If your game crashes, please copy and paste the full error message below, or post a screenshot of it.

No crashes.

Please describe in as much detail as possible how to reproduce the bug or crash.

After updating my game to the latest version (1.1.1) i increased my reputation with Yseros to revered, i received both the revered and exalted quests to return to her altar. I talked to her and both quests resolved, but i only got the rewards for revered (items & deity points). I figured this was just a cosmetic thing so i continued to grind reputation until i was at 4999 thinking i’d still get the exalted rewards. Unfortunately talking to her does nothing, tried to earn some additional rep to see if that would get it working again but no effect, still stuck at 4999 and without the access to robes & 35 deity points etc.

What operating system are you playing the game on? Windows, Mac OS, Android, iOS, or Playstation?
If it’s Playstation, please also state your region (NA or EU). If it’s a mobile device, please state the device’s model/brand (such as Nexus 5 or Samsung Galaxy Tab 4).

Moto E / Android 6

What game version are you playing? You can find the version number on the title screen in the lower left corner.

1.1.1

Thanks for your time, hopefully i can still get the rewards somehow :stuck_out_tongue:

This will be fixed tomorrow, sorry about that!