After latest update very zoomed out, hard to see.

Been enjoying this awesome game a lot during the week.

Updated it yesterday and now on my Nexus devices (5 and 10) the game is so zoomed out it is very difficult to see anything. I saw in the patch notes there was a resolution fix, if this is on purpose I much prefer to have an option to restore it to a more “Full Screen” mode. Is it there and I just can’t find it?

Thanks!

The fix was for the PC, looks like something carried over to smart phones accidentally.

Yes, a bug unfortunately slipped in as a side-effect of this fix. This will be fixed in the next update. I’m sorry about that.

Actually once I got used to it its actually preferable as long as the Realm is a bright one, can be quite hard to see details on the Nexus 5(smaller screen) in a darker realm, especially since the opacity of the controls is not working correctly (almost bright white, even though decreased to the max)… but I still love this game.

I was enjoying the zoomed out view on my Nexus 7. It would be cool to have a tablet view that used it.

I also have a Nexus 7 1st Gen (2012) and with one of the recent patches, the default view is now zoomed in so close that only three tiles are between the character and the top and bottom of the screen. It’s near impossible to form any tactical maneuvers like this as the foes are on top of you before you can turn your “creature train” around to avoid it. Matter of fact, there is little avoiding anything with this view now and it feels very claustrophobic to me.

After contacting Zack, I got a fast reply and then a patch came out the next day. Awesome! However, the view is still zoomed in too close for my taste (unchanged from previous version) and the minimap does appear now in the Menu screen, but not in every map. I went into a Dungeon map after the first map had the minimap working just fine, but in my second map area it had disappeared completely. Am I accidentally disabling this map somehow by hitting a secret button somehow? I know about the long press feature and tried everything…I just don’t know what to do.

I tried my little heart out to play with the view so far zoomed in, but it just seems like it’s futile in trying to make a strategic move in the map. Hopefully some kind of medium will be reached to where everyone is pleased! :slight_smile:

Hey guys, sorry for the frustration. As it turns out, the Nexus 7 improperly reports its resolution to the game which causes the zoom to act very strangely. To solve this problem, I’m going to add specific support for these devices in the next patch. I’m currently aiming for a new release on Monday. I’m very sorry that you won’t be able to play the game this weekend, but thank you for your patience and for keeping me updated on these problems!

I also am developing a game (2 years and counting now) and have read about certain devices such as the Nexus 7 and Galaxy Nexus (which both I own) having some difficulty with this resolution issue. It could be pertaining to the fact those devices have the soft keys which eat up like 22-30 pixels (I forget how many) at the bottom. I ended up including a function within my options screen that detects exactly what the device resolution is (or what it thinks it is) that we are dealing with and prints the result to screen. The result I am getting for the Nexus 7 2012 is 800x1205 (portrait); as we know, this is not a standard resolution! :slight_smile: I ended up hardcoding values for these devices to fix them in particular, but have no clue what it’s doing on other devices quite yet. I am not to that point at this time.

No problem with the growing pains; it comes with the territory! I am still playing the game as I can and trying to get a better feel of things. Plus, it gives me a great excuse to not work on my game this weekend. lol

That’s actually REALLY helpful to know. Thanks a lot! I’ve almost definitely figured out how to fix it, then. I’m going to upload an Android-only patch to the Google Play store shortly that should finally fix the problem.

Out of curiosity, what’s your game like? Do you have a website up for it or is it on IndieDB or anything like that yet?

Edit: It’s been uploaded. If you want it more quickly, keep an eye on the Google Play page so that you can update the game manually. For some reason, many devices only perform automatic updates once per day even when updates are already available.

Yes, those soft keys really put the hurt on the deployment process for everyone. Even when you do the math, the numbers still don’t really make much sense, I recall. There is a ton of dialogue on the subject on the XDA Forums and Unity Forums, as well. Even though they might not be completely relevant, that issue is largely discussed within those realms.

I will keep my eye open on GP today; thanks so much for the amazingly quick responses and lightning fast action! A holiday weekend with World Cup on TV and poor Zack is slaving over the hot coals for us! That is some unbeatable support right there and dually noted!

My game turned into one of those endless sinkholes to where I reached the core goals I had in design, but it simply wasn’t enough for my taste. I went on to expand it and pushed the envelope on the seamless complexity of it all, which meant a ton of behind the scenes functions that would baffle Einstein with the massive walls of multi-dimensional arrays, dynamic lists, and randomized chaos which would attempt to output the story of your experience in English as your reward for an untimely death. Everything in the game is cohesive randomization, and you know exactly how that goes. :smiley: It is indeed getting there, but the path turned out to be much longer than expected.

As a lone developer and party of one, other aspects take a hit in the attention department as the coding portion gobbles 95% of my time. As such, copyrights have not been registered, web page is absent, no GP account just yet as I have nothing to submit at this time. I thought about bringing in a second person, but to sort out and to explain the complexity I created would just hinder things even more. It’s difficult to categorize my game because it’s a hybrid; I might be giving away too much to describe it, but it’s generally a living card game in which the main variables are powered by customized dice and played as a solo board game…kinda. The card titles are long and elaborate and there are 2.1 billion of them (magic number) - all expansions will be included from the start and generated by the game itself. The engine has a custom and elaborate dynamic vocabulary system which logs the game’s events as a novel and keeps tracks of all the crazy stuff the game generates throughout a session. It’s just too big for one person, but I’m still pushing forward and hope to be done by 2020. ;D I am considering taking the donateware path, similar to Pixel Dungeon, to give my contribution back to the Internet; probably the most crazy facet of the project.

So, I’m taking the weekend off and watching World Cup and playing some games, including Siralim!

Hey Zack!

 Thanks so much for the emergency patch and all your efforts with this issue. I also installed the game on my Galaxy Nexus phone and started up a new character (oohhh, do I see cloud saves on the horizon? :) and everything is bingo perfect on that device. We are now back to the normal panned out view and the minimap appears to be there steadily! And there was much rejoicing! Yay!  :D

The Nexus 7 2012 looks fantastic back at the old view and took a good part of my soccer time up playing with the two characters. The only thing is now with this device is that the minimap is now gone completely, apparently. It doesn’t affect me too much as I did not use it prior to the patch anyway (as it was never there), but that middle area is the game play area with no minimap to be had on the Nexus 7 1st gen, just to let you know.

I did fire up my L15 guy and saw the Reincarnation kick in, but I have yet to see how adverse that effect is en masse exactly. I did learn one thing, however; opening a sigil on any level requires some serious contemplation with the HC settings jacked up. :smiley: ;D

P.S. I failed to mention how incredible this game is with the amount of depth and things to do throughout. For me, it reminds me of some of my favorite Wizardry titles with gobs more things to consider and a non-static environment. I really think this Siralim is something unique and special and hope it does well with some more exposure! :smiley:

You mean the entire minimap window is completely gone? It doesn’t even display the type of realm you’re in at the top? There’s not even a black window where it should be? That’s pretty strange. It shouldn’t display while you’re in the castle, but there should be a minimap in every dungeon. I’ll try to figure it out.

Yeah, nothing is there at all. Luckily, there is no black window or anything, just the game map with the menu as usual on the left hand side and the goals/quest boxes to the far right hand side on top. Let me take a picture with my phone and I’ll post what I see up here in a few minutes. Neither device will do screenshots (G-Phone).

Here we go!

https://imageshack.com/i/npynkyj

I can still navigate 100 times more efficiently this way than pre-patch today, though! It feels good to be back and see what I’m doing. :smiley: