All the creatures in my stable are gone :(

Platform: Android
Version 1.3.9

I was putting new properties on my spell gems, holy explosion who i put cast twice and mana reduction on it, when i tried to check my monster i got a fatal error and then all of my creature in my stable were gone. When i try to manage my stable group i can see all of the one i was using with a star but as soon as i try to select it its empty. So maybe the monster are still here ? I don’t really know. Tried to restart my Pixel 2 XL, restart the game too. Nothing worked

I’m sorry that your stables were wiped out. I’ve already uploaded a new patch that you can download to fix this issue to prevent it from happening in the future.

The best I can do is to manually add some of the creatures you can think of that are missing. If there are any rare ones that you can think of, please upload your save file to the cloud at the title screen and send your cloud ID to me at zack@thylacinestudios.com along with a list of creatures and I’ll be glad to add them for you.

Once again, I’m very sorry this happened.