Bug: Action Queue skips the next creature’s turn after an enemy dies

Version 1.2.6 (the bug was also present in earlier versions, but I hadn’t yet figured out how it worked)
Platform: Android

I am encountering a strange issue with the Action Queue that has been affecting the majority of my battles. Sometimes when an enemy dies during its own turn (usually due to damage from debuffs, Curse, or the Live to Labor trait), the turn of the creature that was listed next in the Action Queue is completely skipped over. If my creature was next in the queue, this bug skips its turn at least half the time. Enemy turns are sometimes also skipped in this manner, but not as consistently. Only one turn gets skipped at a time, and the skipped turn is always whichever turn was listed immediately after the now-dead creature in the Action Queue; however, multiple creatures can lose their turns in the same round of battle if additional enemies die.

I have only seen this turn skipping occur after an enemy dies on its own turn. Killing enemies on my own turns does not seem to trigger this bug. I run a team that applies a lot of damaging debuffs like poison, burn, bleed, and curse, and I also have the Live to Labor trait on two creatures, all of which cause enemies to take a lot of damage automatically during their turns. Thus, I am seeing this bug very frequently.

After lots of testing and observation, I can confirm that this turn loss is not caused by any of the following:
-Debuffs (e.g. stun, snare, frozen, sleep) that would normally prevent a creature from acting. This happens to creatures even when they have no debuffs.
-Any trait or spell that shuffles or sends creatures to the bottom of the action queue. When a creature’s turn is skipped, it is not moved lower in the action queue; it just completely disappears from the queue until the next round.
-Traits, like Zealot of the Forest, that cause a creature to automatically sacrifice its turn.

This is happening multiple times in nearly every battle. Normal battles, Nemesis battles, battles triggered by realm objects (e.g. corrupted totems), portal boss battles, and Tavern Brawls are among the battle types that I can confirm to be affected. I don’t have access to Gate of the Gods yet but I suspect this bug would manifest in god battles too. No trait text, debuff text, spell text, or other on-screen text displays to indicate why the creature’s turn was skipped.

For example, let’s say three enemies and three of my creatures are alive, and the enemies have some debuffs. For the next round of battle, the Action Queue lists the creatures’ turns in this order:

  1. Enemy A (debuffs: bleed, poison)
  2. Enemy B (debuffs: bleed, poison)
  3. Ally X (no debuffs)
  4. Ally Y (no debuffs)
  5. Enemy C (debuffs: bleed, poison, curse)
  6. Ally Z (debuffs: blight and scorn, but no turn-canceling debuffs)
    (end of round)

It’s Enemy A’s turn. Enemy A takes damage from bleed, poison, and Live to Labor (x2) but doesn’t die, and acts as normal.

Next, Enemy B’s turn starts. Enemy B takes damage from bleed, poison, and Live to Labor (x2) before it can act. Enemy B dies from this damage.

Ally X is next in the queue, therefore its turn should now start. Instead, Ally X’s turn disappears from the Action Queue immediately after Enemy B dies. I play on Turbo, but even when I wait to read the battle text, no text pops up to indicate that anything has caused its turn to be removed. No extra text shows up in the battle history either. It’s as if, when Enemy B died, Ally X’s turn “died” with it.

Next, Ally Y’s turn begins. Ally Y was not originally the next in the queue after Enemy B, so Ally Y is able to take its turn and act as normal.

Next, Enemy C’s turn begins. Enemy C takes damage from bleed, poison, and Live to Labor (x2) but still has some HP. Enemy C then attacks, causing it to take damage from Curse. Enemy C dies from this damage.
Ally Z’s turn is skipped, the same way Ally X’s turn was skipped.

The round of battle ends without Ally X or Ally Z getting turns. The next round begins with Enemy A’s turn, and so on.

That example is basically what battles are like for me all the time. I’m able to work around it, but it can still be frustrating. I apologize if this post sounds too wordy or redundant. I wanted my description of the bug to be as clear and thorough as possible.

I started this series with Siralim 2, and I love Siralim 3 even more. I hope this bug can be isolated and fixed! Thank you.