Can't build the Hatchery

Hey guys,
I have a problem…
I’m a lvl 47 chaos mage and i can’t finish my castle quest, i got my first nether egg allready but i can’t build the hatchery,
are there special requirements for it? do i have to build the arena before i can build the hatchery? it doesn’t even appear in the list of building-rituals…

Thanks for your help.

Can you tell me what your Castle Quest description says? Does it specifically say that you need to construct a hatchery?

The castle quests are finished, sorry, my fault…
But i still can’t find the hatchery in the building-rituals, so i can’t finish the nether egg.

Could you please send me your save file so I can take a better look?

Assuming you’re playing on Windows, it should be in C:\Users\YOUR_NAME\AppData\Local\Siralim by default and is called siralimX.ini (where X is the save slot). You can e-mail it to me at zack@thylacinestudios.com.

currently I’m playing on IOs, is there a chance to send you the savefile without jailbreak?

Unfortunately, no.

Have you tried talking to Damaos in the War Room again to see if he’ll give you a new Castle Quest?

What was the last Castle Quest you completed? Was it the one to create the egg?

No, i haven’t tried it again, but I’ll do.
Yep, the last one was to create the egg

okay, talking to him again solved the problem…
^^
Thanks for your Help!