Cloud import to steam not working

Please describe in as much detail as possible how to reproduce the bug or crash.

  1. iOS: Exported save game to cloud from iPhone 5
  2. Steam: Changed my CloudID successfully
  3. Steam: Clicked ‘Import’ Option and viewed exported save file successfully
  4. Steam: Confirmed import, got ‘successful’ message
    Result: The game still only gives me the ‘New Game’ option.

Same result when I repeat the process, start the game from its directory instead of through steam or start a new game and save. I can then continue my started game, but still not see my iOS game save.

What operating system are you playing the game on? Windows, Mac OS, Android, iOS, or Playstation?
If it’s Playstation, please also state your region (NA or EU). If it’s a mobile device, please state the device’s model/brand (such as Nexus 5 or Samsung Galaxy Tab 4).

Windows 10, Steam package Ver. 1484790260
iPhone 5 10.2

What game version are you playing? You can find the version number on the title screen in the lower left corner.
iOS: 2.3.3
Steam: 2.3.3