Cloud Save Issues

Hi,

When trying to use cloud save to transfer my desktop save to mobile, I run into a variety of issues.

  1. Often the save transfers up and down correctly, but loading it on Android does not have any of my creatures either in the party or stable.
  2. Sometimes the save will crash when loading with a variable index out of range.
  3. Changing the cloud ID will generally cause the game to crash that persists restart. This is fixable by deleting cloudsave1.sav from the save dir.

My desktop OS is Linux and the mobile is a Samsung Galaxy S7. Version is 1.3.17.

The cloud ID in question is 442884588043.

Thanks!


Sorry for the issues!

I looked into your save files and it seems like only a certain portion of your file is actually being uploaded, which will cause all kinds of data loss. Has this been an on-going issue, or did you just notice it today? It might be that our server is having some temporary issues.

I’ve had the crash after changing Cloud ID before, and saw the stable loss when trying to fix that, but only tried actually loading the save on android recently. I can email you the working save if that would be helpful.

That would be great, thanks! You can send it to zack@thylacinestudios.com.

Sent it. Let me know if any other information would be helpful.

Thank you! I tried to export and then re-import your save file and it seemed to work correctly. Is that what you’re doing to produce the issue, or is there some other step I’m missing?

That is what I am doing, though I changed the cloud ID initially which seemed to precipitate issues when I did. Is it possibly a Linux thing?

I tested on Ubuntu as well and didn’t notice any issues there either. Are you using Ubuntu or something else?

I’m on Arch Linux. Is there any sort of local config that could be an issue? I can try it through wine as well.

Playing with it a bit more, if I go to edit cloud ID, change the first number from 4 to 3 then try to export the game crashes with a 98KB cloudsave1.sav dropped in the Siralim3 directoy. The game won’t load until I delete that file.

There might be some random incompatibility with Arch Linux, but I’m not entirely sure. I’ll try to set up a virtual machine with Arch Linux on it and see if I can reproduce the issue.

I appreciate the prompt and thorough looking into the issue. I’ll try a few more things on my end to see if I can figure anything out. Worst case I can send the save file to an OSX laptop and export there.