Corrupted Cloud Save

To be honest, I’m not that concerned about the save since it was only a few days worth of progress. Already on another cloud ID. I’m just concerned about how likely it is I’ll encounter this bug again. I could just do without cloud saves, but playing on two different devices at home and school is very convenient for me.

If your game crashes, please copy and paste the full error message below, or post a screenshot of it.
Just the standard “Unfortunately, Siralim 2 has stopped” Android popup with buttons for Report and Ok.

Please describe in as much detail as possible how to reproduce the bug or crash.
Open fresh Siralim 2 install, change cloud save ID, select export or import, crashes after it says “obtaining files”. Now when opening Siralim 2 crashes immediately after pressing A on the “Press A to start the game” screen.

Now as to how I arrived at this state of save:
I had already successfully exported/imported a save between two devices for a day (maybe two?) when I tried to do it again.
I was exporting a save (overwriting the cloud one) on my primary tablet when it seemed to get stuck on “uploading file”. Nothing was happening (no error messages, just… nothing happening), so I swipe-closed the app and restarted it, went to Import to check the save, saw it didn’t update. So I tried to export it again, it got stuck again, but this time I waited for several minutes before swipe-closing and restarting. I go to check Import, it looks like my new save successfully overwrote the old one. I go home to my secondary device, select Import, app crashes on “obtaining files” and continues to crash after “Press A to start game” screen.

I ended up clearing data and starting anew on another cloud ID (I still have the corrupted one if you need it). Even on the new ID I’m finding weird behavior but no corruption yet. Example: I’m exporting a lvl 8 save on my primary tablet to a cloud save with a lvl 5 save in the first entry and a lvl 6 save in the second. I select to overwrite the first entry, it gets stuck on “uploading file”, I swipe-close and restart after 30 seconds. I try again, this time selecting the third, blank entry and it’s successful. I go to Import to check and I see a blank first entry, a lvl 6 save in the second, and the lvl 8 save in the third. I go to export again to check whether it’s overwriting saves that’s bugged, but before I select I see the lvl 8 save in the first entry and the lvl6 save in the second, with a blank third entry. I select to overwrite the lvl 8 save in the first entry with my local lvl8 save, it’s successful. I go home to my secondary device, Import the lvl 8 save, it’s successful, and that’s where I’m at now.

I suspect spotty school wifi since I’ve only gotten the stuck “uploading file” on my primary tablet, which I only use at school, but I’ve only been playing a few days so small sample size.

What operating system are you playing the game on? Windows, Mac OS, Android, iOS, or Playstation?
If it’s Playstation, please also state your region (NA or EU). If it’s a mobile device, please state the device’s model/brand (such as Nexus 5 or Samsung Galaxy Tab 4).

Primary on Android 4.4.4 on Vezen T1 (Chinese off-brand)
Secondary on Android 4.4.2 on something I can’t tell.

What game version are you playing? You can find the version number on the title screen in the lower left corner.
2.4.0
I notice that the latest version is 2.4.2, but all installs and reinstalls give me 2.4.0.