Crash in battle

I’d copied the log but Gyazo overwrote my pastebin automatically. It said something about a String, though.


############################################################################################
FATAL ERROR in
action number 1
of Step Event0
for object obj_battlecontroller:

DoDiv :1: Execution Engine - Cannot operate on string type
at gml_Script_bc_EventDamage
############################################################################################

stack frame is
gml_Script_bc_EventDamage (line 0)
gml_Script_bc_CreatureCast
gml_Script_bc_Turn
gml_Object_obj_battlecontroller_Step_0

this is getting more frequent

Still haven’t been able to track this one down. My best guess is that this might be coming from either a Lance artifact or a Shield artifact. Did you recently equip one of these?

My whole team has lances, yes.

Perfect! Do any of their stats look weird to you? For example, their main properties might say something strange like “More Damage Dealt to 100%”, but that’s just a guess.

They all look fine to me.

The crash happens before I even select a spell, and I think every time it’s happened the Twisted Devil went first due to Raid (though it doesn’t happen every time he goes first).

Is your spell list open when it happens? Like it just crashes randomly while you’re trying to pick a spell?

No, it happens as soon as I select “Cast”, before the spell list opens.

Sorry to ask for you to do this for the 100th time, but could you please send your save file to me? I’ll play around and try to reproduce the crash.

Okay but it could take quite a while, it’s pretty random.

Could it have something to do with Strife?

Never mind, it just happened with Strife disabled.

Still getting this crash.

Watching the video I recorded, my Lich Overseer casting necrosis and the game crashing after many battles.
pic 1: Selected cast
Pic 2: Cast necrosis
Pic 3: Game at last crashed with the select a spell for your Lich Overseer to cast displayed.