Crash in battles at the death of the final enemy

  1. Is your issue a bug, or is it a crash?
    Crash

  2. If it’s a crash, please copy and paste the full error message below, or post a screenshot of it. Otherwise, leave this field blank.

  3. Please describe in as much detail as possible how to reproduce the bug or crash.
    There is no error message, the game simply hangs on the final “x has been defeated” message while the last enemy is still on the screen. Sometimes I get get through a few battles before it happens, but rarely can I make it through a whole realm without it hanging. I’ve not finished a daily realm without the crash, for example.

  4. What operating system are you playing the game on? Windows, Mac OS, Android, or iOS?
    Windows 7

  5. What game version are you playing? You can find the version number on the title screen in the lower left corner.
    2.3.0 via Steam

  6. Any other details to help us solve the problem, such as what you were doing when the bug/crash occurred, or any hints on how we can reproduce it.
    I played over 100 hours before this suddenly started. It wasn’t a slow degradation, I went from playing for 5 hours to crashing within 5 minutes of launching the game. Not sure what changed, although I do recall toying with the Turbo mode around that time.

Sounds like it must be a bug with Turbo Mode. Could you please try disabling it and see if that helps?

I disabled turbo and gave it another go. I encountered the hang/crash in the same way at the end of my fifth battle. Another thing to note is that around the time this started happening, I had switched from a normal attack stat damage team to a lich overseer/raven ritualist doom team. As the crash only happens at the end of battles, and doom is the only attack I have, maybe it’s related. (artifacts were also switched along with the team).

Edit:

  1. Changed out team entirely, no more crashing
  2. Changed back to doom team but removed all artifacts, no more crashing
  3. Added their artifacts again, crashed after a few battles. The fact that it doesn’t happen during the first battle makes me think the error happens when a glitchy artifact is leveling up.

Thanks for testing this so thoroughly! That’s a big help :slight_smile:

Could you please tell me which abilities your artifacts grant your creatures?

I tried adding the artifacts back one by one after 10 battles to find the culprit. I got the hang on the fourth artifact (Resurrection Code), so I replaced it with a different one thinking it was solved. Then I got the hang again. It seems possible that the hang is more likely to occur the more artifacts are equipped, perhaps due to the number of calculations required at the end of battle by the various stacked bonuses?

Carver Shadowstalker: Eternal Rest, brimstone, essence, granite, power, energy, player xp bonus
Carver Shadowstalker: Resurrection Code, brimstone, crystal, essence, power, energy, player xp bonus, grant buff magic
Carver Shadowstalker: Resurrection Code, brimstone, crystal, essence, granite, energy, player xp bonus
Lich Overseer: Cloak and Dagger, brimstone, crystal, essence, granite, power, energy, player xp bonus
Raven Ritualist: Final Oblation, brimstone, crystal, essence, power, creature xp, player bonus, grant buff magic
Thunderstruck Phoenix: Chrysaor’s Ambition, brimstone, crystal, essence, granite, player xp bonus

Thanks again for the info! I’ll track this bug down and get it fixed for the next update.