Crash on creating a gem Android 1.0.6

When I select a gem to create from the gem altar, as soon as I confirm the essence cost to creat a gem, i crash with this error:

I am on a Nexus 7 2012 running stock 4.4.2. My Siralim version says 1.0.6 from my app settings, but the title screen shows 1.0.2

I’m very sorry about that. I’m working on a hotfix patch right now and will push it out as soon as possible - hopefully tonight. Thank you for letting me know.

Super cool, I’ll be watching out for it. Just checked the play store and left a review for the interm.