Fatal Error after defied rank fix

Game now crashes upon loading save game.
Was originally having issues with stuck defied rank.
Playing on android.


The good news is that the fix worked. The bad news is that I butchered it, hence the crash. A fix is on the way! Thanks for the screenshot!

Thank you for the reply

It’s uploaded now - just have to wait about an hour or less for Google to process it and it should be all set :slight_smile:

For some reason gonfurians rank still won’t budge past 499/500

Do you have the quest to talk to him?

No, I keep doing the random quests in his area + killing mobs from blood stains and knights, it’s telling me I’m gaining Rep with him but when looking at the bar it stays at 499 .
When I speak to him he doesn’t say anything, brings up the options to spend my deity points etc… when I click that option he just says something about my pockets being filled?

Were you having trouble with other gods as well? If so, are those at least fixed now?

All other gods seem fine, it’s just this one God.

Alright, one last question if you don’t mind: can you open up your completed quest list and see if the quest “Respected by Gonfurian” is on that list?

Hummm, I have acknowledge and respected by gonfurian completed. Odd


That’s perfect, thanks for the fast response.

For the sake of transparency, there were actually two bugs here:

  1. Sometimes, you wouldn’t receive a quest if you were at the maximum amount of favor for the given favor rank. That’s fixed already thanks to yesterday’s patch.
  2. Sometimes, you would complete a quest then get rolled back to the previous level for some reason. That’ll hopefully be fixed today, but if not, it’ll be fixed tomorrow at the very latest.

Thank you very much for the support, just like to say your games are great, I put 190+ hours into siralim 1 and well on the way to exceeding that on siralim 2. I hope this game makes it across to the Xbox one at some point too.

I’ve been kicking around that idea for both Siralim 1 and 2, actually. I’ve already registered with Microsoft and received some development kits, but I’ll have to dig in and see what’s involved with it before announcing anything officially :slight_smile:

Best of luck with that, it would be a day one purchase for me.

Sorry to say, the issue still exists, still not moving from 499 still won’t say what needs to be said when I speak to him.

It wasn’t meant to be fixed in the last update as that was just for the touch controls - it’ll be fixed tomorrow.

Its still stuck at 499 after update :frowning:

Yes, the fix was not included in the last update, it will be fixed tomorrow :slight_smile:

Cheers, didn’t mean to post twice, I hadn’t noticed thread went onto page 2 , thought I must have not posted the first time.