[Fixed] Equipping last artifact.

  1. Is your issue a BUG (such as a glitch, or something that probably shouldn’t happen in the game or a CRASH (causes the game to throw an error and does not allow you to continue playing the game)?

Crash

  1. If your issue is a CRASH, please copy and paste the full error message below. Otherwise, leave this field blank.

############################################################################################
FATAL ERROR in
action number 1
of Draw Event
for object obj_itemmenu:

Push :: Execution Error - Variable Index [0,414] out of range [1,414] - -1.items(100398,414)
at gml_Object_obj_itemmenu_Draw_64
############################################################################################

  1. Please describe in as much detail as possible how to reproduce the bug or crash.

Shrugs

  1. What operating system are you playing the game on? Windows, Mac OS, Android, or iOS?

Win 8

Also sound continued after crash.

This is fixed for the next update, but in order to reproduce the crash, you have to equip a creature that is NOT currently carrying an artifact with a new artifact that also happens to be in the LAST slot of your inventory. Just thought I’d let you know so that you know how to work around it for now. The update will probably be out tomorrow (and it’ll be pretty awesome).

Okay i was still experimenting trying to figure it out. good to know.