Game Crash/Save File Missing

This game is amazing!

  1. Is your issue a BUG (such as a glitch, or something that probably shouldn’t happen in the game or a CRASH (causes the game to throw an error and does not allow you to continue playing the game)? It was definitely a crash, but I’m sorry I didn’t copy the crash report when it happened.

  2. If your issue is a CRASH, please copy and paste the full error message below. Otherwise, leave this field blank.

  3. Please describe in as much detail as possible how to reproduce the bug or crash. I finished the quest to build the gem alter(?) went to make my first gem, a unicorn gem, and the game froze and came up with a fatal error. I restarted the game and loaded my file, saw that I had lost all progress for that session. Unfortunately instead of saving and quitting, I just closed the game. When I went to load my game this morning, My saved game was completely gone.

  4. What operating system are you playing the game on? Windows, Mac OS, Android, or iOS? Macbook Pro 10.9.3

  5. Any other details to help us solve the problem. To test it out, i started another game and hit close instead of quit and save and it deleted that game as well.

thanks!

Sorry about the crash - it’ll be fixed in the next update which will be released either today or tomorrow.

As for your lost save file, I am VERY sorry about that. If that ever happens again, you can find and retrieve a backup of the save file by doing the following:

  1. Open Finder.

  2. Go to “Go --> Go to Folder”

  3. Enter “~Library/Application Support” (without the quotation marks) and hit return.

  4. Open the folder called “com.yoyogames.macyoyorunner”. This is where your save files are located.

  5. Search for files with the “.bak” extension. You’ll probably see files like siralim1.bak, where 1 is the save slot (the top-most slot) found on the in-game Continue Game menu.

  6. Left-click this .bak file, then press the return key. This will allow you to rename the file. Rename it to siralim1.ini, or whatever save slot number you want, then hit return again.

  7. Load the game and the new save file should work.

If it’s already too late for that, I’d be more than happy to build a new save file for you try to get you roughly to the point where you were before the file was lost. If you tell me your name, class, level, and some of the creatures you had, I can make a new one for you. It won’t be exactly the same as your original one obviously, but hopefully it’s at least some form of compensation so you don’t have to do everything all over again.

I’ve also PM’d you with a Humble Bundle key as a further apology for this inconvenience. I am very sorry that this happened and there is no excuse for that.

Make sure that you always choose “Save & Exit” before closing the game on the Mac version. Mac likes to force-close games and it doesn’t allow the game to save properly in some cases, so that’s why this is necessary.

Hi, thanks for getting back to me.
Your instructions were clear, easy to follow, and worked! I was able to restore my save file :slight_smile:
I really appreciate your help. Now to go immolate some more unicorns.

That’s awesome news! Glad to hear it worked.