Imported and Exported Cloud saved files show up blank

  1. Is your issue a bug, or is it a crash?
    Bug.

  2. Please describe in as much detail as possible how to reproduce the bug or crash.

  1. On Window Phone 8.1 device, export a save file to Cloud Storage.
  2. On Android, run Siralim and go to Cloud Storage. Go to Import from Cloud.

Expected Results:
3. The save file exported from Android is there with the correct player name, level, playtime, etc.

Actual Results:
3. The save file is shown as a Level 1 King (Blank) MAGe with 0:00:00 playtime. If this save file is imported, a very buggy save file is loaded that crashes when looking at the creature list/going into a portal/etc etc.

  1. What operating system are you playing the game on? Windows, Mac OS, Android, or iOS?
    This bug only occurs for me when exporting from Window Phone to Android. The same thing happened the other way around.

  2. What game version are you playing? You can find the version number on the title screen in the lower left corner.

Both Android and WP are running 2.3 ,download from the official platform’s store

  1. Any other details to help us solve the problem, such as what you were doing when the bug/crash occurred, or any hints on how we can reproduce it.
    The only broken feature seems to be importing and exporting saves from the cloud between the 2 OS. I will try to install the game on another Android device to test if the same thing happen on the same OS

For the Cloud ID I am using to reproduce this bug 061019944961

Update : The problem didn’t occur between my 2 Android phones. It’s only when I try to export / import from my Window Phone to my Android did the bug happen. It’s bad because it seems like I can’t back up the saved files from my WP to the cloud? Any suggestion guys?

I just checked your files and it looks like the internet connection on your Windows Phone times out before all the data can be transferred. If you’re connecting via 3G or 4G, could you please try using a WiFi connection instead? Or, if you’re currently using WiFi, could you try a 3G or 4G connection instead?

I tried but it doesn’t work…I can download the saved files from my Android to my Window Phone, but I just can’t upload from my WP to the cloud…my 2 androids is using the same WiFi but it works just fine

Btw I live in Japan where WP platform isn’t supported yet… Maybe that’s the issue? I don’t know

My issue at https://forums.thylacinestudios.com/t/1082 seems to be the same. A fresh save becomes a corrupted/empty save file, my older save hangs on upload. I have a feeling it’s all the same problem.

I’m on Windows Phone in Europe and tried both 3G and Wifi. Download to WP works fine, upload never does. I strongly doubt that anyone using WP can currently upload save files to the cloud.