Mac version Crashing After Cloud Import

I attempted to import my save file from the cloud to a Mac, after having uploaded my save from a Windows environment. The crash message I get any time I boot the game, now, is:

Error in
action number 1
of Draw Event
for object obj_titlemenu:

cannot apply sort to negative number.
at gml_script_scr_playerlevel

Could you please give me your cloud ID?

Sure, it’s

Thanks! I can reproduce the issue with my Mac so I should be able to hunt down the problem and get it fixed soon.

Nice!! Great, great work with your response times.

I realize now that this was in the wrong board, and that it was for Siralim 2. I’m sure that you’ve already realized that!

Update to this - if my Windows instance attempts to either load a cloud save or upload one, it receives the same error.

Finally found the problem - this will be included in a hotfix that should be out within an hour. Thanks for your patience!

I am trying, now, with my Mac, but I think that the save file is still corrupted. How do I locate it to remove it from my local machine on Mac?

Should be in USER/Library/Application Support/com.thylacinestudios.siralim2. You’ll probably just need to delete all the cloudsaveX.sav files in there.

It’s looking like, even though I’m an admin, I’m not seeing/accessing any folder for the save data. If I can manage to find it to remove the data, I can verify this fix.

Are you able to find the com.thylacinestudios.siralim2 folder?

No, not so far. I’ve looked in /Library/Application Support - I don’t see an Application Support directory under my user’s folder, though, so I’m thinking it might be hidden from my view.

You could also probably try using the search function in Finder for a file called “config.sav” or “cloudsave1.sav”.

Yeah, neither of those shows any results! And when I boot the game, I just get that error message, so I definitely have to find/delete them for it to work. I’m still just guessing permissions are hiding those files…

That’s possible. If so, let’s try this:

  1. Open the terminal (Go -> Utilities -> Terminal).

  2. Input the following two commands, one at a time:

defaults write com.apple.finder AppleShowAllFiles YES
killall Finder

  1. Finder should relaunch and all hidden files should be visible.

That worked to find/delete the files!!

Now, however, after attempting to view my uploaded cloud save, I got a hard crash. Exceptio info below:

Crashed Thread: 0 MainThrd Dispatch queue: com.apple.main-thread

Exception Type: EXC_BAD_ACCESS (SIGSEGV)
Exception Codes: KERN_INVALID_ADDRESS at 0x0000000023cc8000
Exception Note: EXC_CORPSE_NOTIFY

What do you mean by “view” your uploaded cloud save? What exactly are you doing when that happens?

After changing my ID, I choose “Import From Cloud”. It briefly shows the message that it’s trying to retrieve the data, then I get the crash with stack trace data.

I’m using your same cloud ID and not seeing this error so I’m guessing there’s still a file that needs to be deleted (maybe make a backup of your save files and try to start fresh?). You could also try changing your cloud ID entirely and seeing if that works.

On another note, I’m really sorry about all the work you have to go through just to run this game! It’s not normally this difficult, but the cloud saving stuff seems to have complicated matters quite a lot.