Need Help Heal/Resurrection?PLEASE!

Maybe stupid question, but my avatar name says i like to hang back and heal/resurrect, however every time i loose 1 of my beasts i can not use the 3 heal or 5 resurrection spells game provides. Also my save game has never worked so this is my 6th full restart (little annoying re-inputting same info over and over for restart)??? What am i doing wrong? Please help! :-[

Hi there! Sorry for any trouble you’re having.

You aren’t able to use healing spells on dead creatures, but you should be able to resurrect them. What does the game say when you try to cast the resurrection spell?

Also, what platform are you playing the game on: Windows or Android? There are currently two bugs with saving that will be fixed in tomorrow’s update: 1) if you’re playing hardcore mode, the game won’t save properly, and 2) some Android devices don’t save properly. Once again, those will both be fixed in tomorrow’s update.

I cannot target dead beasts so resurrection is a fail cause live beasts don’t require resurrection. Playing on windows 7/64. Heal spells same prob they target beast that are in attack mode only not damaged beasts. Question was "does created King/Queen avatar attack or heal or res? He/She has no options in battle. Only beasts has attack options. Why have spellbook the king/queen avatar can’t utilize as Kingdom Saviour/Defender?

I just tested both types of spells and they appear to be working fine on my end.

A few things to note:

  1. These spells can only be cast in combat.
  2. When you select the spell to cast, you must also select the creature to cast it on. This means that you might need to use the A and D (default) keys to toggle to the creature that needs it to be cast on first.
  3. Are you playing with Creature Permadeath enabled? If so, this is a VERY difficult mode because your creatures will be dead forever if you don’t resurrect them by the end of battle. You might want to play with this mode disabled until you get used to the game.

Started a whole new game again for the 9th time (save is not working so I restart from begining 9 times) and reached level 7 this time with my life mage, I have 15mana left to cast, cost to Resurrect is 10 mana on spell page , game says do not have enough mana to resurrect!! I keep telling you this problem but you keep giving me basic simple answers/your excuses. I am ready to give game a BIG FAIL with LIFE MAGE spells FAILING!!! I also have the fLaShInG screen problem as mention in other support problems. I have tried to relate these problems before and have received answers that have not given a fix to improve game . Please listen to what I am trying to improve!! These are problems that can be solved. Thanks for your ear.

I am sorry for the frustration, but this is part of the troubleshooting process and I am only basing my answers off of the information you gave to me.

I have once again tested the resurrection spells and they’re working fine on my end. What is the exact name of the spell you’re trying to cast? Is it minor resurrection or just “resurrection”? Could you please take a screenshot of the game when it displays the “not enough mana” message?

You need to update your game version to 1.0.2 to fix the save issue. It is on your Humble downloads page.

Can you take a screenshot of the game when your character is in the overworld so that I can see what you mean by “flashing graphics”?

Sorry to interject here, there is a posting format that users should use when posting on this forums and it is a sticky.

"Please copy and paste the following template into your post and answer the questions provided. Please do not hijack other peoples’ topics - if you want to report an issue, start a fresh topic using this template.

  1. Is your issue a BUG (such as a glitch, or something that probably shouldn’t happen in the game or a CRASH (causes the game to throw an error and does not allow you to continue playing the game)?

  2. If your issue is a CRASH, please copy and paste the full error message below. Otherwise, leave this field blank.

  3. Please describe in as much detail as possible how to reproduce the bug or crash.

  4. What operating system are you playing the game on? Windows, Mac OS, Android, or iOS?

  5. Any other details to help us solve the problem."

As far as the graphics flashing issue i was the one that originally reported this issue and zack has fixed it, it did take a while for us to narrow things down but try adjusting the options given and let zack know if this is still an issue and he will do his best to solve this issue if you can be patient enough to narrow things down. (Edit: By the way this is either a new issue or if it’s been reported it’s been yet to be clarified that these steps do not help by another user to the best of my knowledge. Either way it definitely warrants a new ticket.)

I’m going to give you a visual demonstration of the spellcasting process, can you describe at which point the spell casting process breaks? (there are basic instructions to equipping spells as well, i want to make sure the game doesn’t have a bug that forbids you to equip spells… because stranger things have happened.)

So at which point do you start having issues?

Can you describe your issue more clearly?