Newly crashing on startup: "Cannot apply sqrt to negative number."

I have around 190 hours in the game and just today I started getting this crash when starting the game. It happens every time, so my game is now unplayable with my current save file. I have the PS4 disc from Limited Run and I’ve tried it on both my PS4 and PS5. Was on PS5 when it started. It happened just after I backed up a save to PS+, which I’ve done many times. The only thing I can think of is maybe I accidentally quit while it was saving and it messed up my file, but I’m usually pretty careful about that, so I doubt it. I do have a backup of a save from yesterday morning on a USB, but I got some nice stuff I’d rather not lose. Any chance this can be salvaged? I can transfer and upload my save via USB if that would help.


Unfortunately, that error means the save file is corrupted. As you mentioned, that usually happens when you exit the game mid-save, but a few people have also corrupted their save files by inputting weird text into their notebooks and other text inputs so maybe that was it instead?

I hadn’t made any in-game notes on anything, so I guess I got careless while saving. I guess there’s no way to fix it?

No, it’s corrupted so the data is unusable, sorry.

I see. Thanks for replying. Looking forward to Ultimate on PlayStation :slightly_smiling_face:

1 Like

It happened again a few times today and it definitely wasn’t that I quit while saving. I’ve been waiting for the “Game data saved” text to fully disappear from the screen before quitting. Seems like it might be related to finishing a Prophecy since I haven’t been able to finish my current one without having my save get corrupted. Luckily I’ve been careful about backing up my save, so I didn’t lose much this time. Currently on PS5; will try downloading my save to my PS4 later today and see if it works better.

I’d be really surprised if it’s not due to some input text, then. Try clearing out your entire notebook as well as all creatures notes.

I checked all of my stable creatures carefully and all of them had the generic “You haven’t written notes about this creature” text or whatever it says. Same for every page in the notebook. The only custom text I’ve added is for a few item sets, artifacts, and stable groups, and all of them are nothing but numbers, letters, and spaces. After that, I made a few saves that worked just fine, finished my Prophecy, and got another corrupted save. Haven’t gotten a chance to try it on my PS4 yet, but I really think it’s related to finishing this Prophecy.

Edit: I guess before I switch over to PS4 later, I could try erasing the other custom names I made if there’s an option to do that.

It’s my player level. I’m almost certain of it.

I didn’t see an option to remove names from my item sets, stable groups, and artifacts, so I removed the spaces from all of them and went into a low level realm I could clear quickly. Seemed to work until I went to a higher level realm and leveled up. I can consistently replicate this. Do anything in a low level realm: no issue. Quickly clear a realm at a high enough level that my player level increases: corrupt. Current player level is 555 and I’ve tried reaching both 556 and 557. Both of them cause corruption. Even brought my working save over to my PS4 and was able to corrupt it just by leveling up in a realm.

The cherry on top is that PlayerLevel appears twice in the crash screen, as can be seen in the screenshots I originally posted. They’re both the same screen; I just scrolled down to show the last few lines.