No arrow Keys and buttons since update

Hey guys,
love this game.

But since the update i cant Player on my mobile Device because i cant see the arrow Buttons also neither the a or b Buttons. Im using galaxy s5 with Android obviously.
it seems the Buttons are in the top left corner.

Best regards

Are the buttons functional enough that you can load your save file? If so, try loading the file, then open the menu and go to Options, then Default. This will reset your options and should put the buttons back to where they belong.

No they dont work really. I tried to reinstall the game. After that the Keys were back but next time i start Siralim there were gone again.

Here is a Screenshot


I’ll try to figure out what might be causing this to happen and get a fix out ASAP. Sorry about that!

No worries. I still have my PC version :slight_smile: I just thought i might not be the only one with that problem

You should see an update within the next few hours. I’m hoping that’ll fix the problem but I can’t be sure since this never happens on my tablet or phone so it’s hard to test for it.

Thank you for the quick and competent support :slight_smile:

I’m pretty sure you already know this is 99% certain to be the same bug as the windows phone problem I posted: https://forums.thylacinestudios.com/t/1022

Any ETA on the Windows Phone fix? No updates yet on the store as far as I can see.

Did you try reinstalling, Griefor?

Oh, I thought that’d make it go away one time, then come back like it did for Nau7ic. But I’ve started it a couple times, rebooted my phone and started it again, and it seems to be gone. Ok, thanks.

I mean, the store page doesn’t say there’s a new version, so it’s purely the re-install.

I downloaded the demo a couple of days ago, seem to be having the same problem as described. Running on a Samsung Galaxy Tab 4.

First startup works fine, I get arrows and buttons. 2nd startup does not show the arrows+buttons. Clearing the cache for the app seem to make the arrows and such appear again for 1 startup, thought I dont think its a good workaround as I assume my save gets deleted.

Tried restarting the device and reinstalling through google play multiple times.

Kind of unrelated, I want to buy this game. Do I need to beat the demo to get the option?
I am going on a 13 hour flight in a couple of days and I think this game would be an awesome way to kill some time. I wont be having internet connection during the flight.
Google play does not give me an option to pay right away, however Amazon seem to do.

Any differences?

There is an option in-game to buy the game. Top of the list in the demo version.

Also, samsung has some non-standard code in their android UI which causes problems for a lot of developers

I just bought a Samsung Galaxy Tab 4 so that I can test this out for myself. I can’t reproduce the problem on my Tab 3 or my Galaxy S3 phone so I guess it has something to do with the newer models. Anyway, it should arrive by this weekend and then I can have a fix out sometime next week. Sorry about that!

I just tried it on my Sony Xperia Z2 and I am encountering the same problem on this device…

Could it have something to do with the fact that I only have the demo version? Like first startup works fine, and it doesnt say its a demo in the far left corner.

2nd startup it says (demo) after the version number though no arrow keys or buttons.

EDIT: I found a solution for my problem at least.

Even though the D-Pad/Keys doesnt show up on the screen they are still there, just invisible. Successfuly navigated myself to the in-game options.

Options -> Control -> Touch Controls: D-Pad -> Classic D-Pad
Options -> Control -> Touch Controls: Input Buttons -> Classic Input Buttons

Then saved and exit, now when I restart the game I get both D-Pad + buttons.

Hope this help others who encounter the same problem.