Saved game error

Fatal Error at Action 1 of Create Event at gml_script_scr_Createitem.

It comes up whenever I try to load a saved game and closes the app.

Halp please.

I am on an Android also, playing version 1.3.0.

Sorry to hear that.

Any idea when you started playing the game? Is this save file from a few versions ago, or is it all from 1.3.0?

If you could take a screenshot of the full error that would be very useful.

Just got it Monday. Should be all 1.3.0. I got screenshots but they’re too large to send here. Got anyplace else I can send them?

Sorry, you should be able to attach them properly now. :slight_smile:

Ok, here.


Unfortunately I’ll have to fix your save file manually. Is your device rooted? I can give you instructions on how to send me your save file, then I can fix it and send it back to you.

No idea. Pass me the Instructions and I will see what I can do.

Using a file explorer app:

  1. Browse to \data\data\com.thylacinestudios.siralim\files.
  2. In this folder you’ll see a bunch of files - we’re interested in the files that end in “.ini”, such as Siralim2.ini. The “2” means it’s the second save slot on the list when you continue the game.
  3. E-mail this file to me at zack@thylacinestudios.com.

Doesn’t look like I can at the moment. Ah well. Guess I’ll just start over. Any advice on how to avoid getting that error
Again?

I’m really, really sorry about that. That’s just about the most frustrating and embarrassing thing that can happen as a game developer. Let me know when you get started back up again and I’ll send you some gift codes for some nice items to help you get back on your feet. I know that won’t fully compensate for the time you lost but hopefully it will help a little.

I have only ever seen this error 1-2 times in the past so it’s definitely very rare, but unfortunately I’m still not sure how to reproduce and ultimately fix it. Each time I update the game I try to add small, experimental patches to that part of the code to fix it but it apparently hasn’t solved all the issues quite yet.

Can you give me a brief description of how far along you were? Your character level would be great to know, as well as which Castle Quest you were doing (if any at all). That way I can have some idea as to what the problem might be coming from.

Oh, it’s alright, man. These things happen. I wasn’t TOO far along as it was…Level 30. The Nether Egg quest trying to
Build the Gem temple. Besides, you’ve been very helpful and quick to answer and I already deeply appreciate that. It’s
Rare to find among developers.

I thank you for all of that.

Just as an update. Back on my feet at Level 38, doing well into the Arcane Vault quest and no more problems to
Speak of. Thanks for all your help last week.

Glad to hear it! Thanks for keeping me updated. If you want some free stuff or if there’s a particular creature you’d like to have, feel free to PM me and I’ll give you some gift codes as promised.