SOLVED 0.1.22: Severe lag while loading game and traversing realms [emptying fuse folder fixed it]

I’m running the game under Steam’s Proton on Linux.
I’m at depth 1020.
Over the course of a couple days, the lag has been getting worse and worse.
The game freezes for 30 seconds on the picture of a keyboard screen.
Last night, walking was lagging at like 1/6 speed.
I’ve attached a video and my save.

https://forums.thylacinestudios.com/uploads/default/original/2X/b/bf45133b9a78020d4bc27abca3ad791c327c3c62.mp4 slot1.sav (512 KB)

Walking around in the castle is fine.
Traversing realms just is really laggy now.

There are apparently LOTS of failed sprite draw calls.

Turning off enemy fusion palletes fixed the overworld lag.
Edit: It didn’t fix the battle lag (lots of errors drawings sprites still).

So, the “fuse” folder was 128.9MB!
renaming it to “fuse.bak” brought the controller loading screen down to like 1 second, and battle lag is mostly gone.
I found this out by just copying over the save folder when switching to Windows.

Sidenote: My party has crazy palettes now if the fuse folder is missing.

I loaded up your save file and don’t seem to notice any lag at all, so I am guessing it’s something related to Proton. Your best bet is probably to wait for the Linux port which is coming soon.

The workaround of emptying the “fuse” folder of 36k images worked for me.
Keeps getting filled up over time, so need to empty it every couple hundred realms to keep the lag down.