Upload to cloud hangs on 'Please wait, uploading file to the cloud...'

  1. Bug

  2. Game stays on uploading indefinitely. I’ve waited a few minutes.

  3. Windows Phone

  4. 2.2.1

  5. I’m using WIFI, with data roaming having no connection. When I exit and restart, there is a level 1 ‘King’ file in the cloud slot I was uploading to.

What level is your character? Just asking so I have some idea about how large the save file might be.

At any rate, depending on the file size and your upload speed, it could potentially take a very long time. As far as I’ve seen, the game will never hang at that screen without doing anything, so I’m pretty sure it’s uploading slowly but surely in the background.

Level 94.

Also, I left it running for about 50 minutes without result… :confused: Guess I’ll try again, even longer.

I tried creating a fresh save and uploading that, it’s almost instantly done. But when I check the cloud storage the game is a Level 1 ‘King’ instead of the name I chose.

The level 94 file still doesn’t upload even given hours of time.

I’ll check the weird file name issue out and include a fix in the upcoming patch which should be released this week or next. Sorry about that!

As for the issue with your larger file not uploading, I’m still thinking there’s some issue where your phone is either timing out the connection or your upload speed is getting crunched somehow. I’ll double-check and make sure our servers aren’t timing out after a certain amount of time, though.

Edit: I changed some things on our end to make sure it won’t time out even after a really long time, though I’m not 100% sure if that is the problem anyway.

I’ve tried again on 2.3.0, same results.

What sucks is that Windows Phone doesn’t let me into the file system (not even a workaround, I’ve tried google to find a way), so I can’t manually copy over the save either. I can only access a select few folders like Documents/Videos/Pictures/etc.

If it times out shouldn’t it come back with some error? The fact that it keeps going I’d think would mean that it’s NOT timing out when it really should be. Clientside, at least.