Waiting for Text... significantly. (On Android)

I had a bit of trouble deciding where exactly to put this… however, perhaps it is in fact, an unintended bug?

  1. Is your issue a BUG? I believe so? (Read after 6)

  2. Not a crash

  3. Happened by default, start, restart, different character, new character. All had same result.

  4. What operating system are you playing the game on? Android Samsung Galaxy S5

  5. What game version are you playing? Most recent release from today.

  6. Any other details to help us solve the problem.

Aside from there being no sound; every time I talk to someone, or receive any sort of narrative text (such as the text for opening a chest or reforging artifact) it stays up without me being able to close it or do anything. This lasts at least 10 seconds and will then let me search around for the invisible “B” button to finally close out. It’s making passing this awesome update almost too infuriating. And I’d liked to think I’m pretty patient. :frowning:

I’m having an issue with the music as well and that’ll be an easy fix for tomorrow, but I’m having a hard time reproducing the issue you’re describing with the buttons. I’ll keep trying things and hopefully push out a fix tomorrow for this as well. Sorry for the frustration and thank you for the detailed report.

Awesome! And thank you for the quick response, Zack, you are amazing. It felt like it was something to do with the dialog having a set time to be open, like it was making sure you had time to read it. The pauses were longer for larger texts. As if some unheard voice was saying it and had to read through the whole thing before you could close the window. Just a thought, I’m not a coder yet to give any kind of solid insight. :stuck_out_tongue:

Edit: Ah! Ok, so I tried making another new character. This time the bug didn’t happen! I was so happy. Until, in the first realm, I talked to a merchant (they didn’t show up on the map as anything, like the dwarves and castle members who show up as colored dots, the merchant didn’t) the moment I left him, the bug of no sound and prolonged text occurred! Try recreating it. I’ll keep testing things to see if I can find out any more.

Did the latest update fix the issue for you?

Yes! I’ve done what I can to try and trigger the bug and nothing has been able to recreate the problem. Thank you! This game is fantastic, you are great!

That’s great to hear! Enjoy :slight_smile:

Of course! It’s happened again! I spoke to the cat outside the war room and the bug reappeared. Loss of audio and extended text without the ability to close it.

Edit: However, leaving the app and going back in (without having to close it) cleats the bug, it seems.

What happens if you disable sound in the game options? Does that fix it?

Turns out this was an Android-specific bug with the engine we use to work on Siralim. I just received a notice that this has been fixed, so I will upload a patch now.