Windows 1.0.5 Turning off Values of Zero in the gameplay options doesn't stop 0 hits from making noise

I’m on Windows game version 1.0.5
I’m using Nephilim Shieldbearer and got sick of the constant 0’s, so I turned them off. The game still makes noise as if the 0’s were never turned off. I have since also turned off damage text entirely, and the game still makes the noise, even though it doesn’t seem to do that for any of the other types of battle text since I turned them off. Turning off battle sounds did make the noise stop, but I would rather not have battles muted forever.